马上注册,结交更多好友,享用更多功能,让你轻松玩转社区。
您需要 登录 才可以下载或查看,没有帐号?FreeOZ用户注册
x
本帖最后由 欧阳京 于 17-1-2022 22:47 编辑
Wireless mesh systems are expensive comparing to traditional 802.11ac or 802.11an technologies.
However, you can buy cheap 802.11ac or 802.11an wireless routers or modems and flash OpenWrt into them to build very cheap home wreless mesh system.
For instance, I picked up three TP-Link AC1750 Modems from Facebook for $20 each to replace my existing setup at home as my new place needs bigger wireless coverage than before, when I used wireless extenders which are generally very poor in performance and reliability.
Here is link as to how you can flash OpenWrt into TP-Link AC1750 modems:
https://openwrt.org/toh/tp-link/archer_d7
Note: There are TP-Link AC1750 routers and they are easier to flash than modems but modems come with broadband ISPs so when people switch ISP, they sell them very cheaply.
After flashing, the first thing you will need to do is to connect its WAN port to your home NBN router coming with your ISP so it has internet access. Or you can manually configure wireless client on it but it is so easy.
For example your will need edit two file as following using linux command vi:
vi /etc/config/wireless
config wifi-iface 'wifinet1'
option device 'radio1'
option mode 'sta'
option ssid 'your home wifi'
option encryption 'psk2'
option key 'your home wifi password'
option disabled '1'
vi /etc/config/network
config interface 'lan'
option device 'br-lan'
option proto 'static'
option ipaddr '192.168.0.9' ###This is your mesh node LAN IP, which is used for management, you can configure it when Luci is installed later
option netmask '255.255.255.0'
option ip6assign '60'
option gateway '192.168.0.1' ###This is your exisiting home wifi gateway, normally on your home wifi router provided by your ISP
option stp '1'
config interface 'wwan'
option ifname 'wifinet1'
option proto 'dhcp'
/etc/init.d/network restart
Once it is connected to the Internet, you will need to install and remove something as following:
opkg update
opkg install luci (for web GUI)
(mesh needs new WAP3 encryption, so)
opkg remove wpad-mini wpad-basic
opkg install wpad-mesh-wolfssl
opkg remove ath10k-firmware-qca988x-ct (ct mean Canadian technology, which is not compatible, so remove them)
opkg remove kmod-ath10k-ct
opkg install ath10k-firmware-qca988x
opkg install kmod-ath10k
Then reboot it and add wireless mesh point to your 5G 802.11ac seciton using SAE encryption:
|