标题: How to configure home wireless mesh network using OpenWrt? [打印本页] 作者: 欧阳京 时间: 14-1-2022 10:52 标题: How to configure home wireless mesh network using OpenWrt? 本帖最后由 欧阳京 于 17-1-2022 22:47 编辑
Wireless mesh systems are expensive comparing to traditional 802.11ac or 802.11an technologies.
However, you can buy cheap 802.11ac or 802.11an wireless routers or modems and flash OpenWrt into them to build very cheap home wreless mesh system.
For instance, I picked up three TP-Link AC1750 Modems from Facebook for $20 each to replace my existing setup at home as my new place needs bigger wireless coverage than before, when I used wireless extenders which are generally very poor in performance and reliability.
Here is link as to how you can flash OpenWrt into TP-Link AC1750 modems:
Note: There are TP-Link AC1750 routers and they are easier to flash than modems but modems come with broadband ISPs so when people switch ISP, they sell them very cheaply.
After flashing, the first thing you will need to do is to connect its WAN port to your home NBN router coming with your ISP so it has internet access. Or you can manually configure wireless client on it but it is so easy.
For example your will need edit two file as following using linux command vi:
config interface 'lan'
option device 'br-lan'
option proto 'static'
option ipaddr '192.168.0.9' ###This is your mesh node LAN IP, which is used for management, you can configure it when Luci is installed later
option netmask '255.255.255.0'
option ip6assign '60'
option gateway '192.168.0.1' ###This is your exisiting home wifi gateway, normally on your home wifi router provided by your ISP
option stp '1'
config interface 'wwan'
option ifname 'wifinet1'
option proto 'dhcp'
/etc/init.d/network restart
Once it is connected to the Internet, you will need to install and remove something as following:
opkg remove ath10k-firmware-qca988x-ct (ct mean Canadian technology, which is not compatible, so remove them)
opkg remove kmod-ath10k-ct
opkg install ath10k-firmware-qca988x
opkg install kmod-ath10k
Then reboot it and add wireless mesh point to your 5G 802.11ac seciton using SAE encryption:
[attach]457504[/attach]
[attach]457506[/attach]
[attach]457507[/attach]
After mesh is running as in following picture, create 5G AP and 2.4G AP on nodes in a normal way for your PCs, mobiles and other wifi clients.
[attach]457505[/attach]
As you can see, 802.11ac from a TP-Link AC1750 modem/router can give you 1G and above speed depending how far away the nodes are apart from each other. (the closest distance between my two nodes is about 5 meters, so 975mbit/s ).
All mesh nodes use the same setup as above mentioned.
Then you can enjoy your home mesh network. One good thing I have found is that as long as the mesh node connected to your ISP router is up, rebooting one of three mesh node doesn't cause any traffic outage, therefore you have wifi redundancy to some degrees.
Another thing is, Optus provided WIFI router uses DHCP to to get public IP address, so you can simply replace the Optus router (very bad quality Sagemon 3864) with one of the mesh nodes and enjoy the very fast speed of 1.3Gbps of 802.11ac technology as following : (Better than wired Gibagit Ethernet.)
#####Create wan interface for Internet access via NBN box######
config interface 'wan'
option persist 'true'
option maxfail '0'
option holdoff '10'
option device 'eth0.2'
option proto 'dhcp'
option hostname '*'
###### Put the WAN/LAN port in the same VLAN as eth0, which connects to CPU ####
config switch_vlan
option device 'switch0'
option vlan '2'
option vid '2'
option ports '6t 2 1'